"License Not Found"

"License Not Found"

Postby markp3rry » Fri 02 Dec 2011 16:58

Hi,

I have downloaded a 30 day trial copy of dotConnect for Oracle. Works great on my laptop. Tried deploying my website to a server and got the dreaded "License not found" message from the InnerException when I try to execute a LINQ query.

I have tried copying the license.licx file into the root folder. I have tried pre-compiling the site from the command line ony my laptop and then copying it all to the server. It does not work.

Please can someone at Devart advise? I have to get this working before we can commit to buy the product.

Thanks.
markp3rry
 
Posts: 3
Joined: Fri 02 Dec 2011 16:52

Postby Pinturiccio » Tue 06 Dec 2011 09:20

When you are developing web applications, you have to add the license information to your project manually. You can do it by using License Wizard. The wizard analyzes the current project, informs you about problems found, and performs some actions needed to fix the problems.
If you create the assembly library, which works with the dotConnect for Oracle assemblies, you have to add the license information to this library and specify all the files that can use this library in License Wizard. In this case files which will use this library don't need the license information.
For more details please refer www.devart.com/dotconnect/oracle/docs/?Licensing.html
Pinturiccio
Devart Team
 
Posts: 2024
Joined: Wed 02 Nov 2011 09:44

Licensing

Postby markp3rry » Wed 14 Dec 2011 10:51

I've run Tools --> Oracle --> License Information in VS2010.

I get two messages. The first says "The library has a reference to Devart.Data.Oracle but cannot check if the library is used by an additional executable.". There's a Fix button next to it but I get an access denied to license.licx when I try to do this (I'm running VS2010 in admin mode).

The second says

"Error in the compiled module: License not found. Please view "Licensing" topic in dotConnect for Oracle documentation for details or contact Devart technical support."

How do I sort these out? Please don't just post a hyperlink to a page on your site - tell me what I need to do.
markp3rry
 
Posts: 3
Joined: Fri 02 Dec 2011 16:52

Licensing

Postby markp3rry » Wed 14 Dec 2011 12:05

I have done a little bit more work on this, created the [applicationname].exe.licenses file and added it to the solution together with the licenses.licx file. I've checked Tools --> Oracle --> License Information again and it now says

"The project has correct licenses.licx file."

"The compiled module has correct license information."

I've published the application to my local web folder and then copied the contents onto the remote server but I'm still getting the License Not Found message on the remote server.

Any suggestions?
markp3rry
 
Posts: 3
Joined: Fri 02 Dec 2011 16:52

Postby Pinturiccio » Thu 15 Dec 2011 14:11

Currently, we cannot reproduce the described problem in our environment. Please give us the following information so that we can provide you a step by step walkthrough to resolve the issue:
1. The exact version of dotConnect for Oracle Professional Trial you are using. You can find it in the Tools > Oracle > About menu of Visual Studio.
2. The chain of calls in your approach when opening connection. For example:
MyWebApplication.dll -> MyClassLibrary.dll -> Devart.Data.Oracle.dll.
3. Tell us the exact types of your projects, because, for example, web site and web application have to be licensed in different ways.
4. Send us a screenshot of your Tools > Oracle > License Information window when your solution is opened.

As a workaround, install dotConnect for Oracle in the "Minimal installation" mode in your deployment environment.
Pinturiccio
Devart Team
 
Posts: 2024
Joined: Wed 02 Nov 2011 09:44


Return to dotConnect for Oracle