How to have multiple dotConnect drivers (Oracle + MySQL)

How to have multiple dotConnect drivers (Oracle + MySQL)

Postby mrjoltcola » Fri 26 Aug 2011 00:28

When I install the latest MySQL dotConnect, I start getting errors.

The base class or interface 'Devart.Common.DbTransactionBase' in assembly 'Devart.Data, Version=5.0.302.0, Culture=neutral, PublicKeyToken=09af7300eec23701' referenced by type 'Devart.Data.MySql.MySqlTransaction' could not be resolved

The only way I resolved this in the past was to ensure both Oracle and MySQL dotConnect are at the same level.

What is a better way to resolve this?
mrjoltcola
 
Posts: 24
Joined: Tue 21 Sep 2010 07:17

Postby Shalex » Mon 29 Aug 2011 14:28

Devart data providers use a common assembly (Devart.Data.dll), so it is necessary to install compatible providers versions (they have the same release date):
http://www.devart.com/dotconnect/oracle ... story.html
http://www.devart.com/dotconnect/mysql/ ... story.html
You can find the versions of your current products via the Tools > Oracle (MySQL) > About menu of Visual Studio.

dotConnect for MySQL v 6.30.202 is compatible with dotConnect for Oracle v 6.30.202.
Shalex
Devart Team
 
Posts: 7602
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle