ORA-24813: cannot send or receive an unsupported LOB

ORA-24813: cannot send or receive an unsupported LOB

Postby slaxman » Tue 09 Aug 2011 23:21

This exception happens in a table with NCLOB type as one of the fields while using v6.30. I suspect NLS_CHARATERSET setting which is currently UTF8. The same setting worked fine in your v5.70. There was a field truncation issue with 5.70 with ALF32UTF8 setting. so we had to move to v6.30 which fixed that. this one is a new problem introduced in v6.30. not sure whether the other fix caused the breakage. seems like they are related. can you help?
------
EXCEPTION (Devart.Data.Oracle.OracleException): ORA-24813: cannot send or receive an unsupported LOB
Stack Trace: at Devart.Data.Oracle.ao.d()
at Devart.Data.Oracle.x.m()
at Devart.Data.Oracle.x.c()
at Devart.Data.Oracle.u.a(Int32 A_0, bf A_1)
at Devart.Data.Oracle.OracleCommand.InternalExecute(CommandBehavior behavior, IDisposable disposable, Int32 startRecord, Int32 maxRecords, Boolean nonQuery)
at Devart.Common.DbCommandBase.ExecuteDbDataReader(CommandBehavior behavior, Boolean nonQuery)
at Devart.Data.Oracle.OracleCommand.ExecuteNonQuery()
at Devart.Common.Entity.cd.ExecuteNonQuery()
at Devart.Data.Oracle.Entity.d.k()
-------
NLS settings:

NLS_LANGUAGE AMERICAN
NLS_TERRITORY AMERICA
NLS_CURRENCY $
NLS_ISO_CURRENCY AMERICA
NLS_NUMERIC_CHARACTERS .,
NLS_CHARACTERSET UTF8
NLS_CALENDAR GREGORIAN
NLS_DATE_FORMAT DD-MON-RR
NLS_DATE_LANGUAGE AMERICAN
NLS_SORT BINARY
NLS_TIME_FORMAT HH.MI.SSXFF AM
NLS_TIMESTAMP_FORMAT DD-MON-RR HH.MI.SSXFF AM
NLS_TIME_TZ_FORMAT HH.MI.SSXFF AM TZR
NLS_TIMESTAMP_TZ_FORMAT DD-MON-RR HH.MI.SSXFF AM TZR
NLS_DUAL_CURRENCY $
NLS_COMP BINARY
NLS_LENGTH_SEMANTICS BYTE
NLS_NCHAR_CONV_EXCP FALSE
NLS_NCHAR_CHARACTERSET UTF8
NLS_RDBMS_VERSION 11.2.0.2.0
------
slaxman
 
Posts: 47
Joined: Wed 16 Sep 2009 20:09
Location: United States

Postby Shalex » Thu 11 Aug 2011 16:09

I cannot reproduce the problem with dotConnect for Oracle v 6.30.202 and Unicode database using the sample from http://www.devart.com/dotconnect/oracle/docs/Lob.html#clob (changed the type of the Value column: CLOB -> NCLOB).

Please give us the following information:
a) the exact versions of your dotConnect for Oracle (x.xx.xxx);
b) you are using the Direct mode and the "Unicode=true" connection string parameter, aren't you? Please post here or send us your connection string (roughly, without credentials);
c) send us a small test project with the corresponding DDL/DML script to reproduce the issue in our environment.
Shalex
Devart Team
 
Posts: 7781
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle