Using a GUID as a Primary Key issues

Using a GUID as a Primary Key issues

Postby johnselkirk » Tue 14 Jun 2011 14:03

Hi,

We are using a GUID as a primary key (mobile centric app -- can't use sequence) and there are some quirks.

When retrieving data using EF it will return the values you are looking for including any related data (using Foreign Keys that are also GUIDs) but all of the GUID values that are primary keys have a GUID that did not come from the database. They seem to be newly generated GUIDs.

The model I am using does not have any GUID columns that are not used as either a Foreign Key or Primary Key so I do not know if the problem is with hydrating all GUIDs or just ones used in a Key.

Let me know what additional information you need.

This one is REALLY critical to us so I would appreciate a quick turnaround. I don't even mind testing a quick dev fix/patch!!

This was tested on 6.30.165.0

John.
johnselkirk
 
Posts: 9
Joined: Thu 07 Oct 2010 00:03
Location: US

Postby AndreyR » Wed 15 Jun 2011 07:44

I have sent a small test project to the e-mail address you have provided in your forum profile.
Could you please make some changes in it in order to reproduce the issue or create a project of your own to illustrate the problem?
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby AndreyR » Wed 15 Jun 2011 07:45

I have sent a small test project to the e-mail address you have provided in your forum profile.
Could you please make some changes in it in order to reproduce the issue or create a project of your own to illustrate the problem?
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16


Return to dotConnect for Oracle