Workflow Instance Store bugs

Workflow Instance Store bugs

Postby vifani » Wed 08 Jun 2011 14:33

Hello,
I have found two issues in your Workflow Instance Store.

The first one is about the GetExpirationTime function. I have an exception InstancePersistenceCommandException (The execution of the InstancePersistenceCommand named {urn:schemas-microsoft-com:System.Activities.Persistence/command}SaveWorkflow was interrupted by an error) with an Oracle error ORA-01841. I think the compute of the expiration date is not correct in the GetExpirationTime function and need to be changed into "return sysdate + offsetInMilliseconds / (24*60*60*1000);"

The second one is an InstanceNotReadyException exception when I call the LoadRunnableInstance on an instance of WorkflowApplication class. The exception message is "No runnable workflow instances were found in the InstanceStore for this WorkflowApplication to load."
I have found no workaround to manage this issue. I think that the problem is not how the workflowapplication instance is configured, because the same code using the SqlWorkflowInstanceStore works without problems. Can you help me?

Kind Regards!
vifani
 
Posts: 17
Joined: Thu 05 Aug 2010 16:20

Postby Shalex » Fri 10 Jun 2011 14:35

Thank you for your report. We will investigate the issues and notify you about the results as soon as possible.
Shalex
Devart Team
 
Posts: 7473
Joined: Thu 14 Aug 2008 12:44

Postby vifani » Mon 13 Jun 2011 12:48

I have a new bug for you.

Previous bugs are on Oracle 11.0.2.1.0

Using Oracle 10.2.0.5.0, your Workflow Instance Store is not working. Also a simple workflow persist command thrown an InstancePersistenceCommandException exception:
The execution of the InstancePersistenceCommand named {urn:schemas-microsoft-com:System.Activities.Persistence/command}SaveWorkflow was interrupted by an error

The inner exception is
Inner Exception
---------------
Type : Devart.Data.Oracle.OracleException, Devart.Data.Oracle, Version=6.30.160.0, Culture=neutral, PublicKeyToken=09af7300eec23701
Message : ORA-06550: riga 1, colonna 6:
PLS-00103: Trovato il simbolo "" anziché uno dei seguenti:
begin case
declare exit for goto if loop mod null pragma raise return
select update while with

<< close current delete fetch lock insert
open rollback savepoint set sql execute commit forall merge
pipe
Il simbolo "" è stato ignorato.
ORA-06550: riga 6, colonna 136:
PLS-00103: Trovato il simbolo "" anziché uno dei seg
Source : Devart.Data.Oracle
Help link :
Code : 6550
Offset : 5
Errors :
ErrorCode : -2147467259
Data : System.Collections.ListDictionaryInternal
TargetSite : Void b(Int32)
Stack Trace : at Devart.Data.Oracle.av.b(Int32 A_0)
at Devart.Data.Oracle.bj.a(Int32 A_0, be A_1)
at Devart.Data.Oracle.OracleCommand.InternalExecute(CommandBehavior behavior, IDisposable disposable, Int32 startRecord, Int32 maxRecords, Boolean nonQuery)
at Devart.Common.DbCommandBase.ExecuteDbDataReader(CommandBehavior behavior, Boolean nonQuery)
at Devart.Data.Oracle.OracleCommand.ExecuteNonQuery()
at Devart.Data.Oracle.DurableInstancing.am.a(Boolean A_0)
at Devart.Data.Oracle.DurableInstancing.c.c()

Thank you.
vifani
 
Posts: 17
Joined: Thu 05 Aug 2010 16:20

Postby Shalex » Tue 14 Jun 2011 09:29

We are investigating the problems.
Shalex
Devart Team
 
Posts: 7473
Joined: Thu 14 Aug 2008 12:44

Postby Shalex » Mon 11 Jul 2011 07:13

The mentioned issues are fixed in the latest (6.30.185) build of dotConnect for Oracle. It can be downloaded from http://www.devart.com/dotconnect/oracle/download.html (trial version) or from Registered Users' Area (for users with valid subscription only): http://secure.devart.com/ .

For more information, please refer to http://www.devart.com/forums/viewtopic.php?t=21452 .
Shalex
Devart Team
 
Posts: 7473
Joined: Thu 14 Aug 2008 12:44

Postby vifani » Mon 11 Jul 2011 07:25

Thank you.

I already download the new version and I have sent you another ticket for a new bug.
vifani
 
Posts: 17
Joined: Thu 05 Aug 2010 16:20

Postby Shalex » Thu 14 Jul 2011 06:43

The issue is fixed. Look forward to the next build of dotConnect for Oracle.
Shalex
Devart Team
 
Posts: 7473
Joined: Thu 14 Aug 2008 12:44

Postby vifani » Thu 14 Jul 2011 06:52

Thank you! :)
vifani
 
Posts: 17
Joined: Thu 05 Aug 2010 16:20


Return to dotConnect for Oracle