IIS 7 vs 7.5 - Unable to find provider

IIS 7 vs 7.5 - Unable to find provider

Postby joao88 » Mon 02 May 2011 20:51

Hi, i am using devart oracle provider 6.10 and a silverlight app+asp.net(using
the provider)+oracle+wcf ria services+windows server 2008(iis 7) 32 bits. so
in windows 2008 r2 64 bits the application works fine. When deployed in a windows server 2008 32 bits i get this error:

Unable to find the requested .Net Framework Data Provider. It may not be
installed.

in this post:

http://www.devart.com/forums/viewtopic.php?t=3285

him add this section, end solve the problem:



name="MySQLDirect .NET Data Provider"
invariant="CoreLab.MySql"
description="CoreLab MySQLDirect .NET Data Provider"
type="CoreLab.MySql.MySqlDirectFactory, CoreLab.MySql, Version=3.50.10.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />



in my case this doesn't work(obviously i change provider name,version etc.. like this:
http://www.devart.com/dotconnect/oracle ... yment.html)...can help me with this issue?
joao88
 
Posts: 6
Joined: Wed 12 Jan 2011 20:42

Postby Shalex » Wed 04 May 2011 13:14

1. Please post here your entry to the DbProviderFactories section. Did you place it in *.config of your application or machine.config of your .NET Framework (full path to this machine.config).
2. Are you using Entity Framework, LinqConnect, web providers? Make sure that you deployed your project with all necessary Devart.* assemblies: http://www.devart.com/dotconnect/oracle/docs/?deployment.html.
3. Refer to this threads:
http://www.devart.com/forums/viewtopic.php?t=20682
http://www.devart.com/forums/viewtopic.php?t=20719
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle