Install dc-oracle and dc-postgres on one PC

Install dc-oracle and dc-postgres on one PC

Postby lumpimax » Mon 02 May 2011 12:22

Hello!

Our software uses (and needs) Oracle and Postgres DB.
Until now we bought and used the dcoracle570std to connect visual studio with our oracle databases and for connection to our postgres databases we used npgsql.
Now we bought the dcpostgresql510pro. I downloaded it and during install it tells me a errormessage about invalid devart.data (5.0.242.0 needed, 5.0.143.0 is installed - within dcoracle570).

Now I have uninstalled dcoracle and dcpostgres. Then I installed dcpostgres first (as it has the higher release number).
The same error message appeared again (just with exchanged release numbers for devart.data). I have confirmed the error and installed anyway.

Now it seem to work, but I cannot create license information for oracle any more (see error below). For Postgres the license info was well build.

File or Assembly 'Devart.Data.Design', Version=5.0.143.0, Culture=neutral. System cannot find File. (Translated from german)

How can we solve this?

Thank you!

Best regards,
Markus
lumpimax
 
Posts: 5
Joined: Mon 02 May 2011 12:00

Postby Shalex » Tue 03 May 2011 09:12

lumpimax wrote:Now we bought the dcpostgresql510pro. I downloaded it and during install it tells me a errormessage about invalid devart.data (5.0.242.0 needed, 5.0.143.0 is installed - within dcoracle570).

Devart data providers use a common assembly (Devart.Data.dll), so it is strongly recommended to install compatible providers versions. Compatible versions have the same release date:
http://www.devart.com/dotconnect/oracle ... story.html
http://www.devart.com/dotconnect/postgr ... story.html
You can upgrade to the latest version of a particular provider using your credentials (URL, login, password) that were sent to you after the purchase. If you cannot find our e-mail with credentials, please contact our sales department (sales at devart*com).
lumpimax wrote:Now it seem to work, but I cannot create license information for oracle any more (see error below). For Postgres the license info was well build.

File or Assembly 'Devart.Data.Design', Version=5.0.143.0, Culture=neutral. System cannot find File. (Translated from german)

If you install incompatible versions of Devart providers, try to fix the problem by removing all policy.*.Devart.* files from your GAC. Also make sure that references to the Devart.* assemblies in your project correspond to the particular provider version. For example, you can find assemblies of necessary versions in the folder of provider installation (\Program Files\Devart\dotConnect\Provider_Name).
Shalex
Devart Team
 
Posts: 7377
Joined: Thu 14 Aug 2008 12:44

Postby lumpimax » Wed 04 May 2011 07:33

Hello Shalex!

I have sent a question regarding the upgrade to salesATdevart*com as I have my credentials but I am not able to download the latest version (my license is valid until september 2011). I didn't get any answer so far, but I would need to proceed with developing?


Best regards,
Lumpimax
lumpimax
 
Posts: 5
Joined: Mon 02 May 2011 12:00

Postby Shalex » Wed 04 May 2011 07:40

We have forwarded your request to our sales department.
Shalex
Devart Team
 
Posts: 7377
Joined: Thu 14 Aug 2008 12:44

Postby Devart » Wed 04 May 2011 08:57

Dear lumpimax,

we emailed you credewntials for download the last version.

For further assitance please contact our sales team.

Regards,
Devart Support
Devart
Devart Team
 
Posts: 3032
Joined: Tue 26 Oct 2004 13:51

Postby lumpimax » Thu 05 May 2011 08:05

Perfect!

Now all works properly!

Many thanks for this great service!


Best regards,
Lumpimax
lumpimax
 
Posts: 5
Joined: Mon 02 May 2011 12:00


Return to dotConnect for Oracle