License not found exception after build server upgrade to 6x

License not found exception after build server upgrade to 6x

Postby cglock » Thu 07 Apr 2011 19:39

I just upgraded our build server (Win2008) to 6.10 of dotConnect, now all projects that require 5.x of the provider are failing at runtime with a license not found exception. They all compile fine (their dependencies are local to their project) but fail at runtime.

These apps are all asp.net web applications and we are embedding a licenses.licx file in the main assembly. I can see that the compiler is creating/embedding a .licenses file into the assembly but still at runtime we receive a license not found error. Projects that reference the latest version of the provider work fine. One thing that I noticed when looking at the embedded .licenses info (the part that was readable anyway) was that i could see the latest version 6.10.xxx in there - I don't know if this should really be 5.7.xxx or not.

I have also tried manually (lc.exe) creating the license and embedding that but have had the same result - license not found at runtime.

I've tried most everything listed here: http://www.devart.com/dotconnect/oracle/docs/licensing.html#general

Any ideas? (upgrading everyone is not a good option)

Thanks!
cglock
 
Posts: 4
Joined: Sat 01 Sep 2007 19:01

Re: License not found exception after build server upgrade to 6x

Postby Shalex » Fri 08 Apr 2011 08:23

cglock wrote:One thing that I noticed when looking at the embedded .licenses info (the part that was readable anyway) was that i could see the latest version 6.10.xxx in there - I don't know if this should really be 5.7.xxx or not.

This should be 5.7.xxx, because the license resource is version dependent. Please refer to this thread for detailed explanation.

cglock wrote:I have also tried manually (lc.exe) creating the license and embedding that but have had the same result - license not found at runtime.

You should generate the license resource for the 5.7.xxx version on the workstation where dotConnect for Oracle v 5.7.xxx is installed.
Shalex
Devart Team
 
Posts: 7388
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle