PLS-00553: character set name is not recognized

PLS-00553: character set name is not recognized

Postby leishen » Wed 09 Feb 2011 06:47

Hi,

I'm using dotConnect for Oracle 5.70.180.0.

If I connect to "Oracle Database 10g Enterprise Edition Release 10.2.0.4.0 - 64bit Production", it works, fine.
However, when I connect to another version of Oracle using exactly same codes: "Oracle Database 10g Enterprise Edition Release 10.1.0.5.0 - 64bit Production", it gives me error:
---
PLS-00553: character set name is not recognized
ORA-06550: line 0, column 0:
PL/SQL: Compilation unit analysis terminated
---

Is there any fix for this? Thanks.
leishen
 
Posts: 16
Joined: Mon 20 Sep 2010 09:19

Postby leishen » Wed 09 Feb 2011 07:00

I found a related link here: http://www.devart.com/forums/viewtopic. ... be1fa91c0e

But no solution posted.
leishen
 
Posts: 16
Joined: Mon 20 Sep 2010 09:19

Postby Shalex » Wed 09 Feb 2011 13:44

Please give us the following information to reproduce the issue in our environment:
1) are you connecting via OCI (Oracle Client) or in the Direct mode? If OCI, tell us the version of your Oracle Client;
2) charsets -
a) NLS_LANGUAGE of your database;
b) NLS_LANG of your Oracle Client;
c) code page of your application (execute Encoding.Default.CodePage in your code);
3) your connection string (roughly, without credentials);
4) try using the "Unicode=true;" connection string parameter. Does it help?
Shalex
Devart Team
 
Posts: 7344
Joined: Thu 14 Aug 2008 12:44

Postby leishen » Thu 10 Feb 2011 09:18

I'm using OCI. I did the following things and it solved my problem:

1. update to 5.7.190 (don't know if this related)
2. change NLS_LANG from "AMERICAN_AMERICA.WE8MSWIN1252" to "AMERICAN_AMERICA.WE8ISO8859P1"
3. Added "Home=xxx" to specify oracle home.

Thank you for the help.
leishen
 
Posts: 16
Joined: Mon 20 Sep 2010 09:19


Return to dotConnect for Oracle