Use different versions of dotConnect for differents project

Use different versions of dotConnect for differents project

Postby skoub » Fri 28 Jan 2011 19:11

hi!

i would like to know how to deal with the fact that i have a project that use dotConnect v5.70.190.0 and another one that is on v5.70.170.0 on the same machine.

Since that i can only have ONE version of dotConnect installed for Visual Studio, how can i play with 2 differents version of dotConnect?

alex
skoub
 
Posts: 32
Joined: Fri 21 May 2010 15:47

Postby Shalex » Mon 31 Jan 2011 15:09

Here are two sides of using dotConnect for Oracle:
  • deployment (there is no need to build/re-build assemblies in the deployment environment)
    You can have as many versions of dotConnect for Oracle on your workstation as you want. And each of your applications will use its particular version of our provider. To use this scenario, you should set the Specific Version property of the references to our assemblies to True. In this case you can either copy our assemblies to your deployment environment or run our installation in the "Minimal" mode. Be aware that every dotConnect for Oracle installation package places the policy.*.Devart.* files to GAC. If you use several versions of our provider, you should remove these policy files from your GAC.
  • development (building assemblies)
    The dotConnect for Oracle license resource is built into your assembly when you use our product (.NET component licensing). This resource is version dependent. The license resource of the version, assemblies of which are referenced in the project, will be embedded into the project (remove the policy.*.Devart.* files from GAC before). But there are design time problems in Visual Studio if you install serveral versions of dotConnect for Oracle.

EDIT: correction of the development section
Last edited by Shalex on Wed 29 Jun 2011 15:57, edited 3 times in total.
Shalex
Devart Team
 
Posts: 7460
Joined: Thu 14 Aug 2008 12:44

Postby skoub » Mon 31 Jan 2011 18:33

so whats the solution if i need to use Visual Studio with dotConnect v6 on one project and also use Visual Studio with dotConnect v5?

I understand that i can deploy the version that i want in the bin folder of the project, for example. But how to play with EntityFramework with 2 differents version of dotConnect?
skoub
 
Posts: 32
Joined: Fri 21 May 2010 15:47

Postby Shalex » Tue 01 Feb 2011 10:03

Solution for developing applications with different versions of dotConnect for Oracle on the same machine is uninstall/install-ing provider every time when switching between versions.

Note.
If you are downgrading (higher version -> lower version), and the higher version of the provider for some reason doesn't remove its policy.*.Devart.* files from the GAC, you should delete these publisher policy files manually.
Shalex
Devart Team
 
Posts: 7460
Joined: Thu 14 Aug 2008 12:44

Postby skoub » Tue 01 Feb 2011 17:29

geez.. this solution is not funny at all !

can you tell me if theres any breaking changes between versions of dotConnect? i mean, if i need to do a maintenance on an older project with older dotConnect references, is there any problems to use the new one? i know i need to make some tests but in general, using v5 to v6 is an easy migration?
skoub
 
Posts: 32
Joined: Fri 21 May 2010 15:47

Postby Shalex » Wed 02 Feb 2011 17:15

Please refer to the dotConnect for Oracle revision history.
You can use the Tools > Oracle > Upgrade Wizard menu to upgrade all references in your project to the newer version of the Devart.* assemblies.
If you encounter any difficulties, please contact us.
Shalex
Devart Team
 
Posts: 7460
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle