data type mapping problem

data type mapping problem

Postby atmuc » Tue 07 Dec 2010 07:42

i have a column as NUMBER(1,0) on an oracle table. dotconnect maps this fiels as bool. is it normal? i use microsoft's entity designer.
atmuc
 
Posts: 8
Joined: Fri 08 Oct 2010 08:19

Postby AndreyR » Wed 08 Dec 2010 11:28

Yes, this is a default behaviour.
If you need to change the type of the NUMBER(1) column from boolean to any other type you can do it manually.
If you are using Devart Entity model (.edml), just go to Model Explorer and change the type to the appropriate one in the combo box (don't forget to change the corresponding Store type in the Model.Store node).
If you are using Microsoft ADO.NET Entity Data model (.edmx), open it in XML Editor and change the type manually in the CSDL and the SSDL parts of the model.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby atmuc » Sun 19 Dec 2010 12:55

it is a bad news. NUMBER(1,0) means that you can use 0,1,...,8,9. dotconnect do not behave as default like that.
atmuc
 
Posts: 8
Joined: Fri 08 Oct 2010 08:19

Postby AndreyR » Mon 20 Dec 2010 08:10

We are working on this functionality, but I don't have any definite timeframe for it at the moment.
By the way, we have an open suggestion at Devart User Voice concerning user-defined naming rules.
You can influence our roadmap by voting for this or some other functionality.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16


Return to dotConnect for Oracle