Entity Framework Not showing the connection string

Entity Framework Not showing the connection string

Postby naveen_ramesh » Fri 03 Dec 2010 10:18

Once I select Oracle database and click on the next after selecting the entity framework. The connection string is empty. :shock:
No option to set the server or any other details for the database.

Am I missing something, I am very new to this.

Thanks
naveen_ramesh
 
Posts: 5
Joined: Fri 03 Dec 2010 10:09

Postby AndreyR » Mon 06 Dec 2010 10:40

To add a Devart Entity model (or Devart LinqConnect model) right-click on the project in the Solution Explorer window, choose the Add New Item... option, select the Devart Entity (Devart LinqConnect model) model.
If you want to create a model from database, choose Database First. On the next screen you can see a window to specify the necessary credentials.
If you want to use the Model First approach, you don't need to specify any credentials before the model is created. Design your model, and then run the Update to Database wizard, it will prompt you to enter the credentials. As an alternative, you can go to Database Explorer and specify the connection information after the model is created.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby naveen_ramesh » Mon 06 Dec 2010 12:40

AndreyR wrote:To add a Devart Entity model (or Devart LinqConnect model) right-click on the project in the Solution Explorer window, choose the Add New Item... option, select the Devart Entity (Devart LinqConnect model) model.
If you want to create a model from database, choose Database First. On the next screen you can see a window to specify the necessary credentials.
If you want to use the Model First approach, you don't need to specify any credentials before the model is created. Design your model, and then run the Update to Database wizard, it will prompt you to enter the credentials. As an alternative, you can go to Database Explorer and specify the connection information after the model is created.


I'm using Visual Web developer 2010, and installed devart's dotConnect for Oracle trial version. I don't see the Devart LinqConnect model when I select add new item on the solution. I tried with Visual C# developer also with no luck.
naveen_ramesh
 
Posts: 5
Joined: Fri 03 Dec 2010 10:09

Postby naveen_ramesh » Tue 07 Dec 2010 10:32

Hi Andrey,

I need this to work before we buy out the licenses. Can you please help me on this. We are trying out this provider, only if we find it to be satisfying our requirements we can go ahead and procure our license. But I seem to be stuck in a place where I can do nothing but search for alternatives.

Thanks in advance
Naveen
naveen_ramesh
 
Posts: 5
Joined: Fri 03 Dec 2010 10:09

Postby AndreyR » Tue 07 Dec 2010 16:08

We don't have a technical possibility to provide design time integration with the Express versions of Visual Studio (including Visual Web Developer).
I have posted a workaround for the .edml models here.
As for the Devart LinqConnect model, you can create the model in standalone mode and then add the generated code file(s) to the project.
You will be able to work with the DataContext instance in runtime, but no design time support is available.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16


Return to dotConnect for Oracle