.NET 4.0 & Licensing issue

.NET 4.0 & Licensing issue

Postby SkipFire » Fri 03 Sep 2010 17:40

I have had a web project in Visual Studio 2010 on .NET 3.5 that I just upgraded to 4.0. No other changes were made during the upgrade, just changed the .NET version and then redeployed to the same Windows 2008 server, changed the .NET version on the application pool, and now I get the licensing errors. Every project in the solution has the licenses.licx file and it all worked prior to upgrading to 4.0. When I go into the License information it tells me that 3 projects (web app and 2 business DLLs) have references to Devart.Data.Oracle but cannot check if the library is used by additional executables and has the fix button, but no other errors or warnings, and the web app is what I am trying to run.

How can I fix this licensing issue? The version number on the Devart.Data.Oracle DLL matches the version in licenses.licx, which says:
Devart.Data.Oracle.OracleConnection, Devart.Data.Oracle, Version=5.25.37.0, Culture=neutral, PublicKeyToken=09af7300eec23701

License not found. Please view "Licensing" topic in dotConnect for Oracle documentation for details or contact Devart technical support.
at Devart.Data.Oracle.OracleConnection.Open()
at System.Data.Common.DbDataAdapter.FillInternal(DataSet dataset, DataTable[] datatables, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior)
at System.Data.Common.DbDataAdapter.Fill(DataTable[] dataTables, Int32 startRecord, Int32 maxRecords, IDbCommand command, CommandBehavior behavior)
at Devart.Data.Oracle.OracleDataAdapter.Fill(DataTable[] dataTables, Int32 startRecord, Int32 maxRecords, IDbCommand command, CommandBehavior behavior)
at System.Data.Common.DbDataAdapter.Fill(DataTable dataTable)
at SQLEngines.OracleEngine2.ExecuteToDataTable(CommandDefinition definition) in D:\Source Code\SVN\Source01_WebTeam\ThirdParty\Visual Studio 2010\SQLEngines\OracleEngine2.cs:line 45
at SQLEngines.EngineBase.LoadList(CommandDefinition cd, Factory factory) in D:\Source Code\SVN\Source01_WebTeam\ThirdParty\Visual Studio 2010\SQLEngines\EngineBase.cs:line 75
at SQLEngines.EngineBase.LoadAll(Factory factory) in D:\Source Code\SVN\Source01_WebTeam\ThirdParty\Visual Studio 2010\SQLEngines\EngineBase.cs:line 101
at MyCompany.OracleBusiness._Service.MyCompanyBUTTONS_GetAll() in D:\Source Code\SVN\fcMyCompanyapptest01_MyCompanyDotNet\Visual Studio 2010\MyCompany\OracleBusiness\GeneratedCode\_MyCompanyBUTTONS.cs:line 16
at MyCompany.WebApp.Admin.DashboardButtonManagerList.LoadList() in D:\Source Code\SVN\fcMyCompanyapptest01_MyCompanyDotNet\Visual Studio 2010\MyCompany\WebApp\Admin\DashboardButtonManagerList.ascx.cs:line 24
at MyCompany.WebApp.Admin.DashboardButtonManagerList.Page_Load(Object sender, EventArgs e) in D:\Source Code\SVN\fcMyCompanyapptest01_MyCompanyDotNet\Visual Studio 2010\MyCompany\WebApp\Admin\DashboardButtonManagerList.ascx.cs:line 17
at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
SkipFire
 
Posts: 10
Joined: Thu 16 Nov 2006 19:09

Postby Shalex » Tue 07 Sep 2010 11:19

dotConnect for Oracle supports .NET 4.0 (Visual Studio 2010) starting from the 5.60.124 version. We recommend you to upgrade to the latest (5.70.152 or 6.0.10 Beta) version. Please notify us if upgrade resolves the issue.

You have mentioned that 3 projects in your solution have direct references to the Devart.* assemblies. Are there any assemblies in your solution that use the code from the mentioned 3 projects as a wrapper for the Devart.* assemblies?
Shalex
Devart Team
 
Posts: 7608
Joined: Thu 14 Aug 2008 12:44

Postby SkipFire » Tue 07 Sep 2010 15:01

I will try the upgrade.

2 of the projects use the Devart assemblies, the third project is the web application that consumed the other assemblies.
SkipFire
 
Posts: 10
Joined: Thu 16 Nov 2006 19:09

Postby SkipFire » Thu 09 Sep 2010 15:59

I've been trying to get the updated DLLs, hwoever we are not getting a response from Devart or any help from Component source, and it has been less than a year since we bought. So, looks like at the moment I am still stuck with this problem.
SkipFire
 
Posts: 10
Joined: Thu 16 Nov 2006 19:09

Postby Shalex » Fri 10 Sep 2010 10:52

I have forwarded your request to our sales department. If your e-mail address that you have specified in your profile at our forum is different from the one you used for subscription, please contact Devart Sales Department (sales at devart*com) and specify your subscription e-mail.
Shalex
Devart Team
 
Posts: 7608
Joined: Thu 14 Aug 2008 12:44

Postby Devart » Fri 10 Sep 2010 11:28

Dear Jon Helms,

Unfortunately we couldn't restore info about the license purchased within the last year by your email and company name. We could see your old license for Standard edition version 3.xx. Please send to our sales team your license number or ComponentSource order number.

Regards,
Devart Support
Devart
Devart Team
 
Posts: 3083
Joined: Tue 26 Oct 2004 13:51

Postby SkipFire » Fri 10 Sep 2010 14:37

We got the licensing worked out, and the application is now working. Once we updated to 5.70.152.0 on all our projects and updated the licenses.licx file, it started to work.
SkipFire
 
Posts: 10
Joined: Thu 16 Nov 2006 19:09

Postby Shalex » Fri 10 Sep 2010 15:17

Thank you for notification.
Shalex
Devart Team
 
Posts: 7608
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle