Referencing devart dlls

Referencing devart dlls

Postby dhoenig » Fri 13 Aug 2010 22:10

I'm confused and hoping someone can help me figure this out. I have a solution with a web project and a data access project. The data access project references Devart.Data.dll and Devart.Data.Oracle.dll. I put both dlls in a bin folder because I don't want to use the GAC. My web project references my data access project. When I build my web project the devart dlls do not get copied to my bin folder??? I set the "Copy Local" to true and it still doesn't copy them. It's like it assumes they are in the GAC?? When I run the app on my local box it works fine because I have installed the dlls into the GAC but when I publish to my web server it fails because it can't find them.

Can someone please help me configure this so it works? Thanks!
dhoenig
 
Posts: 16
Joined: Tue 20 Jul 2010 20:33

Postby StanislavK » Mon 16 Aug 2010 12:12

This is the common behaviour for dependent assemblies. Please copy our assemblies to the Bin folder of your solution manually.

Also, please notice that applications that use dotConnect for Oracle should have the proper technical license to be deployed. For detailed information about this, please refer to the corresponding topics of our documentation:
http://www.devart.com/dotconnect/oracle/docs/Licensing.html
http://www.devart.com/dotconnect/oracle/docs/Deployment.html
StanislavK
Devart Team
 
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Postby dhoenig » Mon 16 Aug 2010 18:48

Thank you for the reply! I got it to work, but I'm still confused on something. I put the devart dlls in my bin for and then added a reference to them. But, when I look at the location of the referenced dll it points to the install path of dotConnect. Then when I build it doesn't even copy my dlls to the out folder.

That seems weird to me...
dhoenig
 
Posts: 16
Joined: Tue 20 Jul 2010 20:33

Postby StanislavK » Tue 17 Aug 2010 12:04

Please specify the version of dotConnect for Oracle you are currently using. The problem may occur, e.g., if you copied the assemblies from an older version and installed a newer one. In this case, the compiler checks the policy (policy.5.70.Devart.Data.Oracle.dll etc.) files in the GAC. They point to the newer version of dotConnect for Oracle; as the newer assemblies are present in the GAC only, the references are set to the dotConnect for Oracle install folder.

To resolve the problem, please either set the 'Specific version' property of the reference to true or remove the policy.*.Devart.* files from the GAC. Also, it is recommended to replace the older assemblies with the newer ones to prevent possible version conflicts.

Please tell us if this helps.
StanislavK
Devart Team
 
Posts: 1710
Joined: Thu 03 Dec 2009 10:48


Return to dotConnect for Oracle