.net RIA Services performance

.net RIA Services performance

Postby jerryk » Thu 05 Aug 2010 18:53

Hi,

We are experiencing performance issues with .Net RIA Services. As an example, when we insert 200 rows in a child table it takes approximately 20 seconds.

Is there anything we can do to improve this performance?

Thanks,

Jerry
jerryk
 
Posts: 8
Joined: Mon 02 Aug 2010 18:47

Postby AndreyR » Fri 06 Aug 2010 12:57

Could you please send us (suppot * devart* com, subject "RIA Performance") a small test project reproducing this issue?
This will speed up our investigation.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby jerryk » Fri 06 Aug 2010 22:28

AndreyR wrote:Could you please send us (suppot * devart* com, subject "RIA Performance") a small test project reproducing this issue?
This will speed up our investigation.


I will do that when I get some breathing room next week. I assume based on your response this is not expected behavior. If so,. what sort of performance should we expect to see?
jerryk
 
Posts: 8
Joined: Mon 02 Aug 2010 18:47

Postby jerryk » Fri 13 Aug 2010 23:47

We are still working hard on other issues, but do you have a sample app that integrates WCF RIA service with dotConnect for Oracle?
jerryk
 
Posts: 8
Joined: Mon 02 Aug 2010 18:47

Postby AndreyR » Mon 16 Aug 2010 10:50

We have sent you a small sample illustrating the work with a master/detail insert.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16


Return to dotConnect for Oracle