OracleMonitor not working

OracleMonitor not working

Postby bhav27 » Mon 19 Jul 2010 16:03

Hi
I'm having problem using oracle monitor which was working fine. Suddenly, the tool stopped working and no tracing is done. I've set the IsActive property to true and also the monitor is started but not traces.

One of my colleague ran the same application his seems to run fine.

Can someone advice what is wrong. I'm using version 3.0.2
bhav27
 
Posts: 20
Joined: Tue 20 Apr 2010 11:53

Postby Shalex » Wed 21 Jul 2010 12:12

Please refer to http://www.devart.com/dotconnect/oracle/docs/?dbmonitor.html:
1. Are you running your application and dbMonitor on the same host or you are tracing your application remotely?
2. Make sure that the OracleMonitor object exists and its IsActive property is set to true on the line of program where you are executing some sql against your database (e.g., use the Watch window of Visual Studio).
3. Does dbMonitor trace no events at all or dbMonitor does not trace only some particular queries?
4. Does the problem persist with the newly created applications?
5. Please tell us the exact version of your dotConnect for Oracle. You can find it via the Tools > Oracle > About menu of Visual Studio.
6. Try to localize the problem and send us a small test project to reproduce the issue in our environment.
Shalex
Devart Team
 
Posts: 7460
Joined: Thu 14 Aug 2008 12:44

Postby bhav27 » Thu 22 Jul 2010 09:00

Shalex wrote:Please refer to http://www.devart.com/dotconnect/oracle/docs/?dbmonitor.html:
1. Are you running your application and dbMonitor on the same host or you are tracing your application remotely?
2. Make sure that the OracleMonitor object exists and its IsActive property is set to true on the line of program where you are executing some sql against your database (e.g., use the Watch window of Visual Studio).
3. Does dbMonitor trace no events at all or dbMonitor does not trace only some particular queries?
4. Does the problem persist with the newly created applications?
5. Please tell us the exact version of your dotConnect for Oracle. You can find it via the Tools > Oracle > About menu of Visual Studio.
6. Try to localize the problem and send us a small test project to reproduce the issue in our environment.


I've done all above but still could not get dbMonitor to work. I am using 5.70.140.0 version of dotconnet for oracle. (professional edition).

I've also sent an email of sample project.
bhav27
 
Posts: 20
Joined: Tue 20 Apr 2010 11:53

Postby Shalex » Fri 23 Jul 2010 10:53

We have answered you by e-mail. Probably, the issue is that there is no database interoperation in the project.
Shalex
Devart Team
 
Posts: 7460
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle