ObjectSet generated when using .NET 3.5

ObjectSet generated when using .NET 3.5

Postby stratdaz » Tue 01 Jun 2010 07:05

My project is configured for .NET 3.5.

When I generate code using the Devart Entity Model template in Visual Studio 2010 the ObjectSet class is included.

Since ObjectSet is a .NET 4.0 object my project fails to compile as you would expect.

If I do the same thing with Entity Developer outside Visual Studio I get the option to select a .NET framework.

What do I need to do to have the template generate code for .NET 3.5 inside Visual Studio?
stratdaz
 
Posts: 23
Joined: Tue 04 May 2010 00:46

Postby AndreyR » Tue 01 Jun 2010 09:58

Could you please check that you have the Entity Framework version property set to ".NET Framework 3.5"?
You can find it in the Model Properties (just double-click the model surface).
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby stratdaz » Wed 02 Jun 2010 05:23

Think I must have tried everything but that!

Thanks.
stratdaz
 
Posts: 23
Joined: Tue 04 May 2010 00:46

Postby pokaragat » Thu 03 Jun 2010 18:11

Did the recommendation resolve the issue. For some reason I cannot find the property to change the framework to 3.5.
pokaragat
 
Posts: 23
Joined: Mon 15 Sep 2008 21:09

Postby AndreyR » Fri 04 Jun 2010 13:15

Pokaragat, try to open Devart Entity Model and perform the following steps (depending on the way you are using Devart Entity Model):
Standalone Entity Developer:
Go to Model->Properties.
Visual Studio integration:
Tools->Entity Developer->Model Explorer, press the Model Settings button.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16


Return to dotConnect for Oracle