Version compatibility 5.55 / 5.60 ?

Version compatibility 5.55 / 5.60 ?

Postby fmichael » Wed 07 Apr 2010 14:15

Hello,

I'm currently testing the dotConnect for oracle and I've encountered a problem.

I developped an application with the 5.55.97.0beta version, everything works fine but when I install the new version (5.60), an error occurs :

"An error occured while connecting to the database. The database might be unavailable. An exception of type 'System.Data.EntityCommandExecutionException' occured. The error message is: 'An error occured while executing the command definition. See the inner exception for details.
The inner exception caught was of type 'System.EntryPointNotFoundException', with this error message :'Unable to find an entry point named 'OCIStmtPrepare2' in DLL 'c:\oracle\ora81\bin\oci.dll.'.'.


Does the application developped with 5.55.97.0 version is not compatible with the new version (5.60) ??


Thanks for your help.
fmichael
 
Posts: 1
Joined: Wed 07 Apr 2010 14:05

Postby StanislavK » Thu 08 Apr 2010 10:30

Thank you for your report. We have fixed the problem, the fix will be included to one of the nearest builds.

The problem should not occur with newer Oracle clients. If possible, you may use Oracle client version 9 or higher as a temporary workaround.
StanislavK
Devart Team
 
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Postby goethals.f » Fri 30 Apr 2010 12:49

StanislavK wrote:Thank you for your report. We have fixed the problem, the fix will be included to one of the nearest builds.

The problem should not occur with newer Oracle clients. If possible, you may use Oracle client version 9 or higher as a temporary workaround.


Is the "fix" "new-build" already released.

Because I also have the same error message "Unable to find an entry point named 'OCIStmtPrepare2' in DLL 'C:\oracle\ora81\bin\oci.dll'." with version 5.60.124.0 en Oracle 8 client.

Sadly, I'm no able to upgrade my client, because I still need to be able to access the old oracle 7.3.4 with other progs (and as far iI know, oracle 8 client was one of the lasts which could connect to 7.3.4)


Thx
Fred[/b]
goethals.f
 
Posts: 60
Joined: Mon 18 May 2009 13:17

Postby goethals.f » Fri 30 Apr 2010 13:18

goethals.f wrote:
StanislavK wrote:Thank you for your report. We have fixed the problem, the fix will be included to one of the nearest builds.

The problem should not occur with newer Oracle clients. If possible, you may use Oracle client version 9 or higher as a temporary workaround.


Is the "fix" "new-build" already released.

Because I also have the same error message "Unable to find an entry point named 'OCIStmtPrepare2' in DLL 'C:\oracle\ora81\bin\oci.dll'." with version 5.60.124.0 en Oracle 8 client.

Sadly, I'm no able to upgrade my client, because I still need to be able to access the old oracle 7.3.4 with other progs (and as far iI know, oracle 8 client was one of the lasts which could connect to 7.3.4)


Thx
Fred[/b]


PS: I tried one of my older applications whichs works with 5.35.79 and where I reference explicit those dll's (not the one in programf-iles on my dev-box because that's version 5.60.120.0)

And also with those old dll's referenced and copied local=true --> my app does not run anymore and I get the above error.

So it seems the even I referenced old dll's, the app uses the new ones ? Is this the normal behaviour.

Hopefully I can uninstall the new version and revert back to the 5.35.79, so at least my old apps are running again...
goethals.f
 
Posts: 60
Joined: Mon 18 May 2009 13:17

Postby StanislavK » Wed 05 May 2010 15:49

The 5.60.124 version of dotConnect for Oracle contains the same functionality and fixes as the 5.60.120 build plus the support for .NET Framework v4 and Visual Studio 2010 RTM.

We plan to release the build with the fix in several days.

As for updating the Oracle client, you can install the newer one without uninstalling the older one. Just check that Oracle client 8 is set to be default in your system so that your old applications can work even if the Oracle client which they should use is not set explicitly.

As for using the newer assemblies, this is the expected behaviour. You may set the "Specific Version" property of the references to true to force the application to use older assemblies.
StanislavK
Devart Team
 
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Postby StanislavK » Fri 21 May 2010 16:51

We have released the new 5.70.140 build of dotConnect for Oracle. It can be downloaded from
http://www.devart.com/dotconnect/postgresql/download.html
(the trial version) or from Registered Users' Area (for users with active subscription only):
http://secure.devart.com/

The new build contains fix for the problem with using Oracle Client 8. For more information on fixes and improvements available in version 5.70.140, please see
http://www.devart.com/forums/viewtopic.php?t=18028
StanislavK
Devart Team
 
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Postby goethals.f » Tue 25 May 2010 12:51

StanislavK wrote:We have released the new 5.70.140 build of dotConnect for Oracle. It can be downloaded from
http://www.devart.com/dotconnect/postgresql/download.html
(the trial version) or from Registered Users' Area (for users with active subscription only):
http://secure.devart.com/

The new build contains fix for the problem with using Oracle Client 8. For more information on fixes and improvements available in version 5.70.140, please see
http://www.devart.com/forums/viewtopic.php?t=18028



Ok,

first tests with the newest version. And everything seems working again with the Oracle8 client.

Thx for fixing this issue !!!
goethals.f
 
Posts: 60
Joined: Mon 18 May 2009 13:17


Return to dotConnect for Oracle