"Show All Objects" missing in Entity Developer!

"Show All Objects" missing in Entity Developer!

Postby edvaldig » Mon 14 Dec 2009 15:37

Hi,

Background:
-Version: Visual Studio 2008
-Database: Oracle
-Product: Devart OraDeveloper Tools 2.55 for Visual Studio


I am trying to use the entity developer to create a model for a read only oracle schema. My problem is that the tables I need to access are not under the schema matching the login name, e.g. User: USER@DB needs to access tables at COMMON@DB.SOME_TABLE.
Now you might tell me to do stuff so these tables are included in the USER schema, e.g. by creating views. That is not possible in my case, I have a read only login with no rights but to read from some other schemas, and it will stay that way. The Database Explorer shows no tables, since it doesn't have an option to show all available tables for that user. This option is, however, visible when creating connections via the database explorer inside Visual studio (View->Devart developer Tools->Database Explorer).

We are looking for a permanent solution for accessing Oracle databases in all application development for our department and this seems to be the right tool for us. If you are able to help me solve this within a few days, then you have your self a large customer, we need to sort this out asap.
edvaldig
 
Posts: 5
Joined: Mon 14 Dec 2009 15:21

Postby AndreyR » Tue 15 Dec 2009 11:25

The Show All Objects button is located between the Create or Edit Connection...
and the Refresh buttons in the Database Explorer toolstrip.
We will fix the lack of tooltips in one of the nearest builds.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby edvaldig » Tue 15 Dec 2009 12:39

Excellent, there it is, thank you! For future reference:
Image
edvaldig
 
Posts: 5
Joined: Mon 14 Dec 2009 15:21


Return to dotConnect for Oracle