ORA-12541: TNS:no listener on dotConnect Oracle Mobile

ORA-12541: TNS:no listener on dotConnect Oracle Mobile

Postby Trushar » Sat 31 Oct 2009 13:08

Hi All,

I have just downloaded the trial dotConnect Mobile. Following is my setup

Visual Studio 2008
WM5,6 SDK
Oracle Express 10g

I created a test SmartClient in C#

Following are my steps

Created a OracleConnection
Using the existing database HR in Oracle XE 10g i gave the username as SYSTEM and password with the server as localhost and also tried with 127.0.0.1 (both connections are successful). I am not providing any Sid.


Create a OracleDataAdapter
I created a Select statement by chosing OracleDataAdapter Task and then the 'select text'. Preview shows the right info.

Then I drag and drop a DataGrid on the the CS Form.

Then i create the OracleDataTable and do the same as Oracle Data Adapter. The preview shows the data correctly.

Then I give the datagrid a datasource as the oracleDatatable and make it active.

In my form I can see the data.

Now compile and start the debugging. I use the device emulator to cradle and then while loading it shows this error as

ORA-12541: TNS:no listener

I used lsnrctl start Listener on cmd to start the listener but no effect.

Any help or sample code or procedures much appreciated.

Thanks

Regards
Trushar
Trushar
 
Posts: 4
Joined: Sat 31 Oct 2009 12:50

Update on the situation

Postby Trushar » Sat 31 Oct 2009 22:22

Hi All,

Just to update on the situation. My problem still stands. I have now done few things. Firstly I created IIS direct access so from the internet on a fix IP we can see my ASP.NET application. This gave me the chance to use my WM6.5 device to go on the net using 3G. So I modified my OracleConnection's IP Address to the static IP Address but the problem persists. I can't get to the Oracle database. From my WM6.5 device using Skyfire or IE browser I can access my website with the same IP Address and can see the data been shown by the ASP but when using it over the 3G on an application I am unable to connect.

I have further few questions:

If I connect my device and cradle it. What should be my IP Address in the connectionString of OracleConnection?

I kept 127.0.0.1 which is the local machine but that will be my WM6.5.

Secondly I get a server timeout when I use one of the application provided with the trial version. Is it to do with the real time out or simply it is not able to find the Oracle database on the static IP Address.

Any pointers will be useful.

Regards
Trushar
Trushar
 
Posts: 4
Joined: Sat 31 Oct 2009 12:50

dotConnect IPAddresses

Postby Trushar » Sun 01 Nov 2009 00:36

Hi All,

I am just updating some progress I have made.

I was able to test the program using the NDIS IPAddresses 169.254.2.2 provided on ActiveSync connection. Then I tried WiFi but for some reason my firewall is blocking any pings on my same network even though after disabling the router, Comodo and Windows Firewall still can't ping on the same network the DHCP IPs on Win XP and WM6.5 device.

Created an ad-hoc computer to computer network and that worked. So that leaves me with further questions. How to do this over internet.

WM6.5 using 3G connecting to IIS and using Oracle database.

Any suggestions.

Regards
Trushar
Trushar
 
Posts: 4
Joined: Sat 31 Oct 2009 12:50

Success

Postby Trushar » Sun 01 Nov 2009 01:09

Hi All,

I have managed to make things work. The problem was my firewall was blocking ports and I needed to open 1521. Once open the Ping Demo was straight into the Oracle database over the static IP Address.

So now I can from a WM6.5 device connect directly to my Oracle database via 3G.

Regards
Trushar
Trushar
 
Posts: 4
Joined: Sat 31 Oct 2009 12:50


Return to dotConnect for Oracle