ORA-12541: TNS:no listener Error

ORA-12541: TNS:no listener Error

Postby danielliu8 » Tue 06 Oct 2009 17:57

Hi,

I used dotConnect for Oracle and Entity Frameworks for our asp.net project, everything working fine on my local machine.

But after I deployed to our test web server, could not connect to Oracle 10g database anymore:

Error:
ORA-12541: TNS:no listener

Stack trace: at System.Data.EntityClient.EntityConnection.OpenStoreConnectionIf(Boolean openCondition, DbConnection storeConnectionToOpen, DbConnection originalConnection, String exceptionCode, String attemptedOperation, Boolean& closeStoreConnectionOnFailure)
at System.Data.EntityClient.EntityConnection.Open()
at System.Data.Objects.ObjectContext.EnsureConnection()
at System.Data.Objects.ObjectQuery`1.GetResults(Nullable`1 forMergeOption)
at System.Data.Objects.ObjectQuery`1.System.Collections.Generic.IEnumerable.GetEnumerator()
at System.Linq.Enumerable.Single[TSource](IEnumerable`1 source)
at System.Data.Objects.ELinq.ObjectQueryProvider.b__2[TResult](IEnumerable`1 sequence)
at System.Data.Objects.ELinq.ObjectQueryProvider.ExecuteSingle[TResult](IEnumerable`1 query, Expression queryRoot)
at System.Data.Objects.ELinq.ObjectQueryProvider.System.Linq.IQueryProvider.Execute[S](Expression expression)
at System.Linq.Queryable.Count[TSource](IQueryable`1 source)
at USC.Advancement.Web.ExcelDataEF.loadGridByWorksetCD(String workcd)
at USC.Advancement.Web.ExcelDataEF.btnImportFromWorkset_Click(Object sender, EventArgs e)
at System.Web.UI.WebControls.Button.OnClick(EventArgs e)
at System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument)
at System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument)
at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)


Would you help?

thanks
danielliu8
 
Posts: 33
Joined: Wed 17 Jun 2009 22:59
Location: ca

Postby AndreyR » Wed 07 Oct 2009 08:27

Please correct your connection string in the web.config file (and in other places you use the connection string, if there are any).
This error states that there is no server in the network with the name specified.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16


Return to dotConnect for Oracle