why can not I open oracle connection in my PDA

why can not I open oracle connection in my PDA

Postby SungJu Jang » Mon 10 Aug 2009 03:23

I compiled the samples project in VS 2005,and then i did a test in my PDA.
when I try to connect oracle, I got a error.The exception is "PlatformNotSupportedException".
I already installed .net CF3.5 in my device,and the OS is WIN CE 5.0


위치: System.Text.Encoding.GetDataItem()
위치: System.Text.CodePageEncoding..ctor()
위치: System.Text.Encoding.GetEncoding()
위치: Devart.Data.Oracle.ap.o()
위치: xc.u.a()
위치: Devart.Data.Oracle.ap.ai()
위치: Devart.Data.Oracle.n.x()
위치: Devart.Data.Oracle.aq..ctor()
위치: Devart.Data.Oracle.ad.b()
위치: Devart.Common.DbConnectionFactory.g()
위치: Devart.Common.DbConnectionPoolGroup.i()
위치: Devart.Common.DbConnectionPool.b()
위치: Devart.Common.DbConnectionPool.GetObject()
위치: Devart.Common.DbConnectionFactory.k()
위치: Devart.Common.DbConnectionClosed.Open()
위치: Devart.Common.DbConnectionBase.Open()

SQL> show parameter nls

NAME TYPE VALUE
------------------------------------ ----------- ------------------------------
nls_calendar string
nls_comp string
nls_currency string
nls_date_format string
nls_date_language string
nls_dual_currency string
nls_iso_currency string
nls_language string AMERICAN
nls_length_semantics string BYTE
nls_nchar_conv_excp string FALSE
nls_numeric_characters string

NAME TYPE VALUE
------------------------------------ ----------- ------------------------------
nls_sort string
nls_territory string AMERICA
nls_time_format string
nls_time_tz_format string
nls_timestamp_format string
nls_timestamp_tz_format string


SQL> select * from sys.props$ where name = 'NLS_CHARACTERSET';

NAME
------------------------------
VALUE$
--------------------------------------------------------------------------------
COMMENT$
--------------------------------------------------------------------------------
NLS_CHARACTERSET
KO16MSWIN949
Character set
SungJu Jang
 
Posts: 1
Joined: Mon 10 Aug 2009 03:04

Postby Shalex » Mon 10 Aug 2009 16:57

Please make sure you have set the Unicode=true; parameter in your connection string.
Shalex
Devart Team
 
Posts: 7304
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle