ExecuteMethodCall Invalid datatype : PL

ExecuteMethodCall Invalid datatype : PL

Postby talsja » Wed 15 Jul 2009 08:35

Hello,

I am using linq to oracle datacontext with oracle 9 as underlaying database.
When i execute a stored procedure with input and output parameters from my C# class i get a Invalid datatype : PL error

Does anyone know what this means and what to do about this?

Thanks a lot

Talsja
talsja
 
Posts: 7
Joined: Tue 14 Jul 2009 11:11

Postby AndreyR » Wed 15 Jul 2009 10:22

Does this problem persist in the latest build of dotConnect for Oracle (5.25.37)?
If so, please send us (support * devart * com) the script of the procedure and a sample code calling it.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby talsja » Wed 15 Jul 2009 13:24

Dear AndreyR

I have purchaced dotConnect520Pro just a few weeks ago so i assume this is the latest version.

Now i am using devart linq to sql datacontext and have implemented all my tables and stored procedures. After your support on the input and output parameters i get the error invalid datatype: pl while executing the stored procedure. What i have noticed is that all my number(10) witch in c# are int64 are bind in the linq to sql class to a double.
Also numbers(7,4) are bound to doubles where i would expect decimals.
I have tried to rebind to the correct types but still have the same problem.

I will send u a email with the codeblock i am using and the stored procedure.

Thanks in atvance

Talsja
talsja
 
Posts: 7
Joined: Tue 14 Jul 2009 11:11


Return to dotConnect for Oracle