Can't publish via ClickOnce after installing dotConnect

Can't publish via ClickOnce after installing dotConnect

Postby davide_lenza » Thu 05 Mar 2009 16:45

Hi,
I can't publish via ClickOnce after installing dotConnect for Oracle 5.2 beta also if the project is not using at all the dotConnect dlls

Can you help me?

Davide

Error 1 The "DevartEntityDeploy" task could not be loaded from the assembly C:\WINDOWS\Microsoft.NET\Framework\v3.5\Devart.Data.Entity.Build.Tasks.dll. Could not load file or assembly 'Microsoft.Data.Entity.Build.Tasks, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified. Confirm that the declaration is correct, and that the assembly and all its dependencies are available. Pioneer.Allocations.Start
davide_lenza
 
Posts: 5
Joined: Thu 05 Mar 2009 13:19

Postby AndreyR » Fri 06 Mar 2009 10:39

This problem is probably associated with the fact that .NET Framework 3.5 Service Pack 1 is not installed on your machine.
I will let you know as soon as this bug is fixed.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby AndreyR » Fri 06 Mar 2009 10:45

As a temporary workaround, you can uninstall dotConnect and reinstall it without the "Entity Developer" feature.
Last edited by AndreyR on Fri 06 Mar 2009 15:16, edited 1 time in total.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby davide_lenza » Fri 06 Mar 2009 11:01

I have found a different workaround. I have simply renamed the following files. No more compilation problems now

C:\WINDOWS\Microsoft.NET\Framework\v3.5\Devart.Data.Entity.Build.Tasks.dll_aaa
C:\WINDOWS\Microsoft.NET\Framework\v3.5\Devart.Data.Entity.targets_aaa
davide_lenza
 
Posts: 5
Joined: Thu 05 Mar 2009 13:19

Postby davide_lenza » Fri 06 Mar 2009 16:17

Installing .NET Framework 3.5 Service Pack 1 has fixed the problem. Thanks for your help!!!!
davide_lenza
 
Posts: 5
Joined: Thu 05 Mar 2009 13:19


Return to dotConnect for Oracle