Missing Data in the results.

Missing Data in the results.

Postby Ronak » Tue 07 Jun 2005 16:49

Hello,

I have a oracle 8i DB and OraDirect.net 3.0 provider.

I have a simple SQL query "select * from xyz"
This xyz table has 12 fields.

In a C# web project I have a OracleDataAdaptor that has this as the select query. I have created a dataset based on this OracledataAdaptor. I have a datagrid that has the dataset as the datasource.

When I run this from my production server, the page works just fine and the datagrid is populated with the data without any issues, but when we move the files over to the deployment server, only the first 6 fields of the datagrid get filled and the rest remain blank.

I tried using a stored procedure to return a cursor and have also used a OracleDataReader instead of the dataset. I have changed the order in which the fields are returned and also tried getting the data from a different table but everytime it works perfactly on the production server but as soon as we move the files over the deployment server it keeps returning the first 6 fields only.

I am unable to understand what is causing this problem.

Please help.

Thanks and Regards,
Ronak.
Ronak
 

trial version on deployment server

Postby Ronak » Tue 07 Jun 2005 18:42

Sorry friends,

It seems that the server was not upgraded to the full version from the trial version and that is what was causing the problem.

Ronak.
Ronak
 

Postby Paul » Wed 08 Jun 2005 05:55

It is possible. Try to uninstall trial version, delete all CoreLab.Oracle.dll from your compute an install OraDirect again.
Paul
 
Posts: 725
Joined: Thu 28 Oct 2004 14:06


Return to dotConnect for Oracle