OraDirect.NET 2.50.1 for .NET2.0 and VS2005Beta2

OraDirect.NET 2.50.1 for .NET2.0 and VS2005Beta2

Postby Guest » Tue 07 Jun 2005 09:23

When I compile a project in Visual Studio 2005 Beta2 using the OraDirect.NET 2.50.1 Provider (for .NET 2.0) I get the following compilation error:

The base class or interface 'System.Data.ProviderBase.DbDataReaderBase' in assembly 'System.Data, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' referenced by type 'CoreLab.Common.DbDataReaderBase' could not be resolved c:\Program Files\CoreLab\OraDirect.NET2\CoreLab.Oracle.dll Data

Seems it doesn't work with VS2005Beta2!
The version of the assembly System.Data is 2.0.50215.
When I install the OraDirect.NET 3.00 Provider (only Trial version) the compilation succeed.

Do you plan to release a Microsoft Visual Studio .NET 2005 Beta 2 compliant provider for OraDirect.NET 2.50.x?
Or do we have to buy OraDirect.NET 3.00 when working with VS2005Beta2?
Guest
 

Postby Paul » Wed 08 Jun 2005 06:02

OraDirect .NET can work Visual Studio 2005. We do not plane to support Visual Studio 2005 or greater in OraDirect.NET 2.50
Paul
 
Posts: 725
Joined: Thu 28 Oct 2004 14:06

Postby Guest » Wed 08 Jun 2005 09:22

Hy Paul

thank you for your reply!

OraDirect .NET can work Visual Studio 2005

That means only OraDirect.NET 3.00 or greater works correct with Visual Studio 2005?
So we have to buy the OraDirect .NET Data Provider Professional a second time?

But for me one question is still open: why can we download an OraDirect.NET 2.50.1 Provider for .NET Framework 2.0 when we can't really use it with the .NET Framework 2.0? (oranet250pro2.msi)
Guest
 

Postby Paul » Wed 08 Jun 2005 09:43

oranet250pro2.msi works with Visual Studio 2005 Beta 1 only.
OraDirect .NET 3.0 supports .NET Framework 2.0 Beta 2 and will support .NET Framework 2.0 Release
Paul
 
Posts: 725
Joined: Thu 28 Oct 2004 14:06


Return to dotConnect for Oracle