Problem with IIS x64 deployment

Problem with IIS x64 deployment

Postby ecardenas » Wed 27 Aug 2008 10:56

Hi

We are migrating our ASP.NET Applications from .NET 1.1 to .NET 2.0, the final deployment will be to a x64 Windows 2003 Server. At the same time we are migrating some WinForms apps too.

Some of our applications depends on OraDirect so we have upgraded and licensed the new version (4.70.22.0 at that moment), the migration in WinForms and my development machine (XP x86) were fine, no serious issues found.

We have some ClassLibrary working as DAL built around the OraDirect functionality.

The first problem appeared when we tried to compile the DAL in x64 Release mode, getting this error message: : Error 1 "sgen.exe" exited with code 1. C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets 1902 9

So, I tried to compile in x64 Debug mode, this time without problems, so I believed that this would be enough in the deployment...(wrong!)

After I recompiled my ASP.NET App in x64 Debug mode, and moved to my test Server, the main assembly loads, but when trying to use some module that relies in OraDirect we get the following message:

Se ha intentado cargar un programa con un formato incorrecto. (Excepción de HRESULT: 0x8007000B)
Descripción: Excepción no controlada al ejecutar la solicitud Web actual. Revise el seguimiento de la pila para obtener más información acerca del error y dónde se originó en el código.

Detalles de la excepción: System.BadImageFormatException: Se ha intentado cargar un programa con un formato incorrecto. (Excepción de HRESULT: 0x8007000B)

[BadImageFormatException: Se ha intentado cargar un programa con un formato incorrecto. (Excepción de HRESULT: 0x8007000B)]
OciDynamicType.nativea(Int32 ) +0
OciDynamicType.a(Int32 ) +75
CoreLab.Oracle.h..ctor(Boolean A_0, Boolean A_1, OracleHome A_2) +1933

We don't want to configure our IIS as x86, since we have other applications (that are not using OraDirect) deployed in x64 working without problems. So we need to know what to do in order to deploy CoreLab in x64 IIS.

Best Regards
Ernesto
ecardenas
 
Posts: 9
Joined: Wed 27 Aug 2008 10:37

Postby Shalex » Wed 27 Aug 2008 15:42

Please make sure you are using Oracle client that supports x64 mode. OraDirect .NET 4.70 should work at x64 Windows 2003 Server correctly and deploy in IIS without problems.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby ecardenas » Wed 27 Aug 2008 19:05

Thanks, I'll try that tomorrow.

Do you think that would be a good idea to uninstall the current x86 drivers first? or just install the x64 version over it?
ecardenas
 
Posts: 9
Joined: Wed 27 Aug 2008 10:37

Postby Shalex » Thu 28 Aug 2008 09:46

Oracle client x64 can be installed just in another home folder.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle