Problem with VS 2008 Entity Framework Beta 3 EDM Wizard

Problem with VS 2008 Entity Framework Beta 3 EDM Wizard

Postby Devman » Fri 13 Jun 2008 16:16

Hi,
I have installed the latest version of ORADirect.NET as of today (13/06/08). When i go into the Entity Data Model Wizard, i click the "New Connection..." button expecting the wizard to take me to another dialog to choose the provider. However the wizard just closes without any further dialogs/errors.

This wizard worked before i installed ORADirect and susequently works now i have removed it.

Any Ideas?

Devman
Devman
 
Posts: 5
Joined: Fri 13 Jun 2008 16:05
Location: UK

Postby Alexey.mdr » Tue 17 Jun 2008 09:21

Hello,

Do you have Visual Studio 2008 SP 1 beta and .NET Framework 3.5 SP 1 beta installed?

Regards,
Alexey.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby Alexey.mdr » Tue 17 Jun 2008 09:28

Hello again,

This was a bug of Microsoft EDM wizard that has already been solved in the mentioned updates.
You should uninstall EF beta 3 and EF Tools beta 3 and install the new updates.

Regards,
Alexey.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby Devman » Tue 17 Jun 2008 10:16

Thanks for the reply.

Ideally, We didn't really want to install VS2008 SP1 beta on our development machines but I guess we may have to do this to get it to work.
Devman
 
Posts: 5
Joined: Fri 13 Jun 2008 16:05
Location: UK

Postby Alexey.mdr » Tue 17 Jun 2008 12:26

You can fix the mentioned bug in the old version of OraDirect .NET and EF beta 3 by opening an Oracle connection in the Server Explorer.
But please note EF beta 3 is not compatible with latest EF updates.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24


Return to dotConnect for Oracle