OraDirect .NET provider disapeared after upgrade to 4.70

OraDirect .NET provider disapeared after upgrade to 4.70

Postby msX » Mon 02 Jun 2008 15:15

Currently I am using the trail version of OraDirect .NET (purchasing process for the professional edition has been already started)

I used OraDirect .NET 4.60 with VS 2008 and used it together with ADO.NET Entity Framework beta 3 - the OraDirect .NET provider could be choosen in the EDM-Wizard/"Update from Database Dialog". Everything was OK.

After upgrading to 4.70, the OraDirect .NET provider disappeared. I also upgraded to VS 2008 SP1 beta 1 (with .NET 3.5 SP1 beta), but I can't still find the OraDirect .NET provider. I de-installed, re-installed and so on, but no OraDirect .NET provider is available in the EDM Wizard. Thus I cannot use ADO.NET Entity Framework now :-(

This problem is only related to the "Model Browser" of the ADO .NET Entity Framework, I find the OraDirect .NET provider for example for "classic" ADO.NET usages.

OS: Vista Ultimate, Visual Studio 2008 Prof (with and without SP1 beta1), .NET Framework 3.5 (and SP1 beta1), Oracle 10 Enterprise
msX
 
Posts: 7
Joined: Mon 02 Jun 2008 15:06

Postby Alexey.mdr » Tue 03 Jun 2008 07:39

Hello,

First of all make sure EF beta 3 (plus EF beta 3 tools) have been uninstalled.
In the new build of OraDirect .NET a stand-alone EDM wizard has been recalled.
Instead you should use standard MS Visual Studio 2008 build-in EDM wizard.
To get started please follow this guide line:
- go to Solution Explorer;
- right click on the project Add -> New Item;
- in the dialog box choose “ADO.NET Entity Data Model”;
- select “Generate from database”;
- create a “New Connection”;
- in the Change Data Source dialog select “Oracle Database”;
- make sure Data provider property is set to: OraDirect .NET;
- continue through out the wizard steps.

Hope this helps.
Regards,
Alexey.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby msX » Tue 03 Jun 2008 08:43

Exactly that I did. The problem is that I do not find any "Oracle Provider" here.
msX
 
Posts: 7
Joined: Mon 02 Jun 2008 15:06

Postby shawnf » Tue 03 Jun 2008 18:46

Just to say I have the same problem.
I downloaded 4.7 as we are using LINQ to Entities (SP1 Beta) and wanted to try it out with an Oracle provider.
I hadn't installed a previous version and I am just using the trial.
No Oracle provider is present in the EDM wizard.
shawnf
 
Posts: 1
Joined: Tue 03 Jun 2008 18:43

Postby Alexey.mdr » Wed 04 Jun 2008 10:26

This is the problem of the Trial editions.
We have already fixed it.
Currently we are making new builds.
They will be available for download in a day.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby SCHRANK » Thu 05 Jun 2008 13:28

I have the same problem.

Is the new trial available?


thx
SCHRANK
 
Posts: 6
Joined: Thu 05 Jun 2008 12:42

Postby Alexey.mdr » Mon 09 Jun 2008 07:33

The build is available for download now.
See the changes here:
http://crlab.com/forums/viewtopic.php?t=12286
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24


Return to dotConnect for Oracle