Problem installing ADO.NET Entity Framework

Problem installing ADO.NET Entity Framework

Postby Horst Tappert » Mon 26 May 2008 16:18

Hey there,

I've tried the whole day to install ADO.NET EF 3 beta without success.
I run VS 2008 Team System without SP and .NET Framework 3.5 SP1 Beta. Before updating the .NET framework i had 3.5 running.

I can install EFB3SetupX86.exe (basic 1.0 EF) successfully but the needed hotfix (KB945282) to update to Beta 3 of EF can not be installed. The setup says there is no software installed to update with this hotfix. HOW COME ????!?!?!

Can anyone recommend me something? I need the ADO.NET EF to create a model file via "Add item" and then to get the classes for the tables of the DB.

Thanks in advance...
Horst Tappert
 
Posts: 4
Joined: Mon 26 May 2008 16:11

Postby Alexey.mdr » Mon 26 May 2008 16:26

Hello,

Could you please specify the version and edition of OraDirect .NET?
We are actively working to support new update (.NET 3.5 SP 1 beta) now.
A new build is expected in the nearest days and as you may have known the new update for the .NET Framework is not compatible with EF beta 3.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby Horst Tappert » Mon 26 May 2008 16:41

Hi,

thanks for the fast answer.
I thought the SP1 of .NET 3.5 comes with the EF included!?

The version of my OraDirect .NET is 4.60.34.0

So, can you tell me what my work around would be right now or is it just impossible to get it going?

Thanks a lot
Horst Tappert
 
Posts: 4
Joined: Mon 26 May 2008 16:11

Postby Horst Tappert » Mon 26 May 2008 16:43

Oh, and its the trial edition downloaded today. I'm right in the middle of testing it for our purposes as we need an adapter to the EF and CoreLab seems to be the only reasonable alternative.
Horst Tappert
 
Posts: 4
Joined: Mon 26 May 2008 16:11

Postby Alexey.mdr » Tue 27 May 2008 06:56

I suggest waiting for couple of days and get the OraDirect .NET version that supports .NET 3.5 SP 1 beta because:
1) the project you develop with EF beta 3 won't run on the machine with .NET 3.5 SP 1 beta.
2) in the .NET 3.5 SP 1 beta there were many changes in EF and bug fixes.
3) OraDirect .NET will use standard build-in EDM wizard.
Summary: I suggest uninstalling EF beta 3, EF Tools and current version of OraDirect .NET, and installing:
- Microsoft Visual Studio 2008 Service Pack 1 Beta
http://www.microsoft.com/downloads/deta ... laylang=en
- Microsoft .NET Framework 3.5 Service pack 1 Beta
http://www.microsoft.com/downloads/deta ... laylang=en
- OraDirect .NET the newest version that is coming soon.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby Horst Tappert » Wed 28 May 2008 08:34

Hi Alexey,

thanks a lot for the info. Will wait then.
Can you give me rough estimation of days for the new release? 1? or 10?

Thanks
Horst Tappert
 
Posts: 4
Joined: Mon 26 May 2008 16:11

Postby Alexey.mdr » Wed 28 May 2008 13:00

Hello!

We are in our final testing now.
So in one-tree days we will announce a product release.
Keep an eye on the forum announcements.

Regards,
Alexey.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24


Return to dotConnect for Oracle