How can I connect to Oracle7.3.4 using OraDirect Mobile

How can I connect to Oracle7.3.4 using OraDirect Mobile

Postby ZhouJian » Tue 22 Jan 2008 04:20

Dears,
I try to use Oracle database by Mobile,Oracle10G is no problem,but when try to connect Oracle7.3.4 version,it is not successful,Somebody can help me.
ZhouJian
 
Posts: 17
Joined: Tue 22 Jan 2008 04:14

Postby Alexey.mdr » Tue 22 Jan 2008 11:56

Try to connect in Direct mode.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby ZhouJian » Thu 24 Jan 2008 05:50

I download the latest Mobile version(4.35),try to use Direct=true,but it is not support this mode. How to do,downgrade to the old version?Thanks
ZhouJian
 
Posts: 17
Joined: Tue 22 Jan 2008 04:14

Postby Alexey.mdr » Thu 24 Jan 2008 10:30

We tested the last build of OraDirect .NET Mobile(4.35.28.1) with Oracle server version 7.3.4 and haven’t encounter the problem with connection.
Could you specify the error message?
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby ZhouJian » Fri 25 Jan 2008 02:31

The big problem is only showing me one attention message window,no detail message and error code.
Ok,I try to get the New mobile one for CF1.1,and test again,later reply the result.Now say"Thanks" .
ZhouJian
 
Posts: 17
Joined: Tue 22 Jan 2008 04:14

Postby ZhouJian » Fri 25 Jan 2008 03:18

Now,I got the images ,please check the follow,thanks
this one is to oracle 7.3
Image
this one is to Oracle10G
Image
ZhouJian
 
Posts: 17
Joined: Tue 22 Jan 2008 04:14

Postby Alexey.mdr » Fri 25 Jan 2008 17:24

We couldn't get this error.
Try running your project in runtime and see the text of OracleException.
If there is no text send us please the callstack, where this exception occurred.
Could you reproduce this error on the installed Oracle client (for example using SQL Plus application)?
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby ZhouJian » Mon 28 Jan 2008 03:09

I try to test all the parameters,I can get this ex.GetHashCode=322977,ex.message="",So how to do my next step.
Thanks
ZhouJian
 
Posts: 17
Joined: Tue 22 Jan 2008 04:14

Postby ZhouJian » Mon 28 Jan 2008 06:21

code=1017
errorcode=-2147483648
CoreLab.Oracle.OracleException
CoreLab.Oracle.g.e()
CoreLab.Oracle.a1.c()
CoreLab.Oracle.u.c()
CoreLab.Oracle.av..ctor()
CoreLab.Oracle.ac.e()
CoreLab.Common.DbConnectionFactory.k() CoreLab.Common.DbConnectionPoolGroup.i() CoreLab.Common.DbConnectionPool.a() CoreLab.Common.DbConnectionPool.GetObject() CoreLab.Common.DbConnectionFactory.j() CoreLab.Common.DbConnectionClosed.Open() CoreLab.Common.DbConnectionBase.Open() CoreLab.Oracle.OracleConnection.Open() DeviceApplication1.FormConnection.Button1_Click() System.Windows.Forms.Control.OnClick() System.Windows.Forms.Button.OnClick() System.Windows.Forms.ButtonBase.WnProc() System.Windows.Forms.Control._InternalWnProc() Microsoft.AGL.Forms.EVL.EnterMainLoop() System.Windows.Forms.Application.Run() DeviceApplication1.FormConnection.Main()
ZhouJian
 
Posts: 17
Joined: Tue 22 Jan 2008 04:14

Postby ZhouJian » Mon 28 Jan 2008 06:40

I try to search the code=1017 in this forums,I get two people's questions like mine
Christian:exception while connected to oracle8i
qhonge:Can I use OraDirect.Net to develop pocket Pc(with wireless) application?
How to solved it?
ZhouJian
 
Posts: 17
Joined: Tue 22 Jan 2008 04:14

Postby Alexey.mdr » Mon 28 Jan 2008 15:09

This is the reason of connection failure:
ORA-01017 invalid username/password; logon denied
Cause: An invalid username or password was entered in an attempt to log on
to Oracle. The username and password must be the same as was specified in a
GRANT CONNECT statement. If the username and password are entered together,
the format is: username/password.

What exactly causes this failure is still questionable.
What Windows regional settings do you have on the server and the client?
What charsets do you have in your database? (select * from nls_database_parameters)

Try connecting to the server v. 7.* via client.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby ZhouJian » Tue 29 Jan 2008 01:31

by sql/plus,I used this username/password@sid format,work good,by oracle client and toad tool,It's work well,and I get the server parameter by"select * from nls_.....",the total list like this:
PARAMETER VALUE
NLS_LANGUAGE AMERICAN
NLS_TERRITORY AMERICA
NLS_CURRENCY $
NLS_ISO_CURRENCY AMERICA
NLS_NUMERIC_CHARACTERS .,
NLS_DATE_FORMAT DD-MON-YY
NLS_DATE_LANGUAGE AMERICAN
NLS_CHARACTERSET ZHS16GBK
NLS_SORT BINARY
NLS_CALENDAR GREGORIAN
NLS_RDBMS_VERSION 7.3.4.3.0
ZhouJian
 
Posts: 17
Joined: Tue 22 Jan 2008 04:14

Postby ZhouJian » Tue 29 Jan 2008 01:53

I try others wrong username/password as you say.Yes when I execute it,will popup the same error null charater message,but as you say I should type the username/password together,how to define the connection string?please/thanks,now my connection string is "user id=inventory;password=inventory;sid=rt;server=127.20.11.1",But I use this one to Oracle10G connection and work good.
Please/Thanks
ZhouJian
 
Posts: 17
Joined: Tue 22 Jan 2008 04:14

Postby Alexey.mdr » Tue 29 Jan 2008 14:36

The problem may be here:
Code: Select all
NLS_CHARACTERSET ZHS16GBK

We are investigating this problem.
I'll let you know our progress.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby ZhouJian » Wed 30 Jan 2008 00:58

Ok,Thanks your attention this,I waiting,maybe can mail me

jian zhou@auchan com cn
thanks
ZhouJian
 
Posts: 17
Joined: Tue 22 Jan 2008 04:14

Next

Return to dotConnect for Oracle