Visual Studio 2008 Prof. Bug

Visual Studio 2008 Prof. Bug

Postby ahijazi » Sat 29 Dec 2007 11:53

Dear CoreLab Team;

- I have download the OraDirect 4.35 from your site, try to test it on VS2008 Pro Edition,

- When trying to add a new Data Set from Data-> Add New Data Source, i press "New Connection" button and then Change the provider to OraDirect.net, then fill connection string and test it, the test is successed.
and Click the Ok, the message appear as follow:
-----------------------------------------------------
Unable to Add Data Connection:
VSDataObjectSupport(524,14)
VSDataObjectSupport(42,16)
VSDataObjectSupport(9,9)
VSDataObjectSupport(825,4)

---------------------------------------------------

- I have used VS 2005 with 4.30 OraDirect and faced no problem, Does your products suppert VS 2008.


Best Regards,
Ahmed Hijazi P.Eng.
ahijazi
 
Posts: 44
Joined: Mon 01 Oct 2007 11:13

Having exact same problem

Postby amit » Tue 01 Jan 2008 13:34

Trying to use ADO .NET EntityFramework in VS2008, no luck so far.

Can open connection in VS2005.
amit
 
Posts: 10
Joined: Tue 01 Jan 2008 13:28

Postby Alexey.mdr » Wed 02 Jan 2008 11:39

This problem is being fixed now.
Try to use Tools -> Oracle -> DataSet Wizard...
instead of standard Data-> Add New Data Source.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby Alexey.mdr » Wed 02 Jan 2008 12:47

Trying to use ADO .NET EntityFramework in VS2008, no luck so far.

We tested the product with ADO .NET Entity Framework Beta 3, probably you have got ADO .NET Entity Framework Beta 2. Check if the examples are working correctly.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby ahijazi » Wed 02 Jan 2008 13:52

Thanks for your reply "Core Lab Team"....

I hope you fix this issue as soon as possible, I have test the two way of creating and editing the dataset,(1) Tools-> oracle-> Dataset Wizard, and (2) Add Dew Data Source, I found that using the (2) is more easier specially for customizing the Data Set after creating it

Best Regards,

Ahmed P. Eng.
ahijazi
 
Posts: 44
Joined: Mon 01 Oct 2007 11:13

Postby Alexey.mdr » Wed 02 Jan 2008 14:07

We reproduced the problem and now we are fixing it.
Look forward to the next build.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby amit » Wed 02 Jan 2008 17:12

I'm using entityframework 3.

Your pre defined examples do open OK.

Why doesn't your provider seen when trying to update a model from database in entity framework edm model? It is seen only when using Data -> Add new data source (but than gets the error above).

On edm model your provider is not seen.

Connecting through your dataset connection screen does work, but this does not let me drag&drop tables to entityframework model anyway.
amit
 
Posts: 10
Joined: Tue 01 Jan 2008 13:28

Postby Alexey.mdr » Thu 03 Jan 2008 16:35

We are investigating this problem.
I'll let you know our progress.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby Sleepyhead » Fri 04 Jan 2008 19:26

I also have the problem with the Entity Framework Beta 3, the provider doesn't appear in the list of providers in the Entity Data Model Wizard.
Sleepyhead
 
Posts: 2
Joined: Fri 04 Jan 2008 19:20

Postby Alexey.mdr » Wed 09 Jan 2008 10:20

This bug is being examined. We will notify you about the result in the nearest time.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Have You a date ?

Postby montemmi » Fri 11 Jan 2008 10:27

Dear support,
is possibile to give us a date for this problem resolution ?

Thank You very much.

Mirko
montemmi
 
Posts: 3
Joined: Fri 11 Jan 2008 10:25

Postby Alexey.mdr » Fri 11 Jan 2008 11:47

We intend to release a new build next week.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Have you some news ?

Postby montemmi » Fri 18 Jan 2008 10:04

Dear support,
have You a precise date ?
I waited a week..but if the new version (solving this bug problem) wouldn't be available during the nexts days I reinstall Visual Studio 2005 on my machine.

Thank You for Your answer.

Mirko
montemmi
 
Posts: 3
Joined: Fri 11 Jan 2008 10:25

Postby Alexey.mdr » Tue 22 Jan 2008 15:07

New build of OraDirect .NET version 4.35.28 is available for download now.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Thank You

Postby montemmi » Tue 22 Jan 2008 21:48

Dear support,
thank you very much.Now it seem to be ok...

Mirko
montemmi
 
Posts: 3
Joined: Fri 11 Jan 2008 10:25

Next

Return to dotConnect for Oracle