OS Authentication

OS Authentication

Postby uhillig » Fri 16 Nov 2007 10:06

Hello,

I'm using OraDirect for connecting to an Oracle 10g database server. For authentication we use OS authentication. When we use the 10g instant client everything works fine. Our problem is, that the customer need to use an Oracle 8 client for connecting to the 10g database.

When we try to do a connection over OraDirect through the Oracle 8 client, OS Authentication will not work!

What we have to do to get this work with the Oracle 8 Client?

Best Regards

Ulf
uhillig
 
Posts: 6
Joined: Fri 16 Nov 2007 10:00

Postby Alexey » Fri 16 Nov 2007 12:36

Please specify your connection string.
Just for your information, for OS authentication mode you should not set username or password in your connection string. It ought to look like this:
Code: Select all
oracleConnection1.ConnectionString = "Data Source=oracle;";
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby uhillig » Fri 16 Nov 2007 13:45

I dont't set these information. If i connect through a 10g client, everything is fine. But 8 won't work.
uhillig
 
Posts: 6
Joined: Fri 16 Nov 2007 10:00

Postby Alexey » Fri 16 Nov 2007 14:37

But 8 won't work.
What is the full version?
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby uhillig » Sat 17 Nov 2007 13:32

The client version should be 8.1.x.x
uhillig
 
Posts: 6
Joined: Fri 16 Nov 2007 10:00

Postby uhillig » Thu 22 Nov 2007 11:47

Are there any news on my problem?
uhillig
 
Posts: 6
Joined: Fri 16 Nov 2007 10:00

Postby Paul » Fri 23 Nov 2007 07:56

Oracle client 8.1 supports OS Authentication. Possibly the problem is in Oracle client settings.
Paul
 
Posts: 725
Joined: Thu 28 Oct 2004 14:06


Return to dotConnect for Oracle