OraDirect .net mobile problem

OraDirect .net mobile problem

Postby halmo » Mon 09 Jul 2007 11:05

CoreLab.Oracle.OracleConnection' does not contain a definition for 'Direct'

Why?

Help me!

Halmo
halmo
 
Posts: 9
Joined: Mon 09 Jul 2007 10:27

Postby Alexey » Mon 09 Jul 2007 11:59

Mobile applications cannot connect to Oracle in non-direct mode. So there is no need in having 'Direct' attribute in the connection. Just erase it out of your connection string.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby halmo » Mon 09 Jul 2007 12:35

The ConnectionString is "Data Source=192.168.1.211;User Id=kmok;Password=ct;Port=1521;Pooling=false;Unicode=true;SID=ecostat10g".
The error message: "NET: Invalid SID".

Do you have any idea what is the reason of this exception?

Thanks
Halmo
halmo
 
Posts: 9
Joined: Mon 09 Jul 2007 10:27

Postby Alexey » Tue 10 Jul 2007 07:17

Do you have any idea what is the reason of this exception?
Yes. Your SID is invalid. Please check it carefully. Try to connect to your Oracle server from desktop application or using another client.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby halmo » Tue 10 Jul 2007 07:36

My tnsnames.ora :
ECO10G =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = TCP)(HOST = 192.168.1.211)(PORT = 1521))
)
(CONNECT_DATA =
(SERVICE_NAME = ecostat10g)
)
)

The PL/SQL Developer and another desktop application works fine.
halmo
 
Posts: 9
Joined: Mon 09 Jul 2007 10:27

Postby Alexey » Tue 10 Jul 2007 08:25

I've sent you our Ping demo project (zipped and renamed to *.txt file). Please try to connect to your server using this demo. If you don't succeed, this would mean that the problem somewhere in your connection settings and not in OraDirect .NET itself.
If you don't receive it, inform me and provide me with another e-mail address that would not reject attachments.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby halmo » Tue 10 Jul 2007 09:11

Alexey wrote:If you don't receive it, inform me and provide me with another e-mail address that would not reject attachments.

I don't receive it, pls. try this: halmo77@yahoo.com
halmo
 
Posts: 9
Joined: Mon 09 Jul 2007 10:27

Postby Alexey » Tue 10 Jul 2007 11:16

Re-sent.
Please wait a bit, we have minor network problems.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby halmo » Wed 11 Jul 2007 06:05

Alexey wrote:Re-sent.
Please wait a bit, we have minor network problems.

I don't receive it.
halmo
 
Posts: 9
Joined: Mon 09 Jul 2007 10:27

Postby Stada » Wed 11 Jul 2007 06:42

Try to set a ";" to the end of your connection string!
Stada
 
Posts: 5
Joined: Thu 24 May 2007 09:25

Postby halmo » Wed 11 Jul 2007 07:22

I tried, doesnt resolve
halmo
 
Posts: 9
Joined: Mon 09 Jul 2007 10:27

Postby Alexey » Wed 11 Jul 2007 09:58

halmo wrote:
Alexey wrote:Re-sent.
Please wait a bit, we have minor network problems.

I don't receive it.
Please check your mail.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby halmo » Wed 11 Jul 2007 10:48

You were right!

The service_names is ecostat10g, but the instance_name is ecostat1.

New connectionstring: "Data Source=192.168.1.211;User Id=kmok;Password=ct;Port=1521;SID=ecostat1".
OracleConnections works fine.

Thanks
halmo
 
Posts: 9
Joined: Mon 09 Jul 2007 10:27

Postby Alexey » Wed 11 Jul 2007 14:04

Not at all.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43


Return to dotConnect for Oracle